Информатика, вопрос задал cristianotonaaaldo , 6 лет назад

определите количество отрицательных элементов в массиве
a=[-4, 3.5, 7, - 1, 0, - 6.1, 4]
k=0
for i in range (7)​

Ответы на вопрос

Ответил 0smash0
0

Ответ:

a=[-4, 3.5, 7, - 1, 0, - 6.1, 4]

k=0

c=0

for i in a:

   if a[k]<0:

      c+=1

   k+=1

print('Количество отрицательных элементов в массиве: ',c)

Объяснение:

Python:

k -- индекс элемента,который  мы берём,чтобы взять элемент из массива

с -- счётчик отрицательных элементов

Новые вопросы