Информатика, вопрос задал fenya1077 , 7 лет назад

Огэ 20.2. Паскаль.
Требовалось написать программу, определяющую количество трехзначных чисел, кратных 3.
Я написал: if (x>99) and (x<999)and (x mod = 0)
Then i:= i+1

Снимут ли балл за (x<999) ,а не (x<1000)

Ответы на вопрос

Ответил Oxmieeee4on
0

Var

A:array[1..3]of integer;

P,k:integer;

Begin

P:=3;

While p>0 do begin

If a[p]<9 then begin

Inc(a[p]);

P:=3;

If (a[1]>0)and((a[1]*100+a[2]*10+a[3]) mod 3 = 0 then inc(k);

End

Else begin

A[p]:=0;

P:=p-1;

End;

End;

Writeln(k);

End.

Попробуй эту прогу

Ответил Oxmieeee4on
0
Там где mod 3 забыл скобку,программа работает выдает 300 чисел как и положено
Новые вопросы