Информатика, вопрос задал RWQFSFASXC , 7 лет назад

Очень важно!
Умоляю помогите! Написать программу, которая находит сумму, произведение и среднее арифметическое 5 целых чисел.​


restIess: на каком языке программирования?
RWQFSFASXC: нужно написать программу, которая находит сумму, произведение и среднее арифметическое 5 целых чисел. :')
restIess: ну дак на каком языке программирования то?)
RWQFSFASXC: я не понимаю слегка :')
restIess: Ну программы пишутся на разных языках программирования)
RWQFSFASXC: в паскале! вот
restIess: С++, C#, Pascal, PHP, python, что-нибудь из этого знакомо?)
RWQFSFASXC: вспомнил ;v;
restIess: а, понял
RWQFSFASXC: спасибо огромное! ^^

Ответы на вопрос

Ответил restIess
1

var

_sum, _multiplication, x, i : integer;

begin

_sum := 0;

_multiplication := 1;

writeln('Введите 5 чисел: ');

for i := 1 to 5 do

begin

readln(x);

_sum := _sum + x;

_multiplication := _multiplication * x;

end;

writeln('Сумма этих чисел:', _sum);

writeln('Произведение числе:', _multiplication);

writeln('Среднее арифметическое:', _sum/5:5:2);

end.


RWQFSFASXC: о боже!!! огромное спасибо тебе!!!!!!!!!!!!!!!!!!!!!! :'D
restIess: обращайся)
RWQFSFASXC: а как удалять старые вопросы? я просто не очень разобрался здесь ;w;`
restIess: Самостоятельно ты не можешь удалить старый вопрос, если на него никто не дал ответ, то можно попросить спамаута/модератора/антиспамера
restIess: А если ответ уже дали, то вопрос не удалят
RWQFSFASXC: а ты вроде антиспамер? qwq
restIess: Угу
RWQFSFASXC: если не трудно, можешь удалить мои старые вопросы? :'D
restIess: Уже
RWQFSFASXC: спасибочки! ^^
Новые вопросы