Очень срочно!!! Составьте программу решения квадратного уравнения, если заданы его коэффициенты в условном операторе (If...then...else...)
Ответы на вопрос
Ответил vadikborisenkov
0
program kvadrurav;
var
a:integer;
b:integer;
c:integer;
d:integer;
begin
Writeln('введите число а');
Readln(a);
Writeln('введите число b')
;Readln(b);
Writeln('введите число c');
Readln(c);
d:=b*b-(4*a*c);
if d>0 then Writeln('x1=',(-b-Sqrt(D))/(2*a),' ','x2=',((-b+Sqrt(D))/(2*a))) ;
if d=0 then
Writeln('x1=',-b/(2*a))
else
Writeln('нет корней');
var
a:integer;
b:integer;
c:integer;
d:integer;
begin
Writeln('введите число а');
Readln(a);
Writeln('введите число b')
;Readln(b);
Writeln('введите число c');
Readln(c);
d:=b*b-(4*a*c);
if d>0 then Writeln('x1=',(-b-Sqrt(D))/(2*a),' ','x2=',((-b+Sqrt(D))/(2*a))) ;
if d=0 then
Writeln('x1=',-b/(2*a))
else
Writeln('нет корней');
Ответил vadikborisenkov
0
так?
Новые вопросы