Информатика, вопрос задал L4mer , 2 года назад

Очень срочно пожалуйста

Напишите программу которая находит среднее арифметическое всех чисел записанных в файле в столбик и выводит результат в другой файл


Аноним: А числа какого типа? Целые или вещественные?
Аноним: И какой тип файла - текстовый или бинарный?
L4mer: Целый. Текстовый
Аноним: Игры в Паскаль?
L4mer: Паскаль

Ответы на вопрос

Ответил Аноним
13
var
  n,d,s:longint;
  mid:real;
  f:Text;
begin
  n:=0; s:=0;
  Assign(f,'input.txt'); Reset(f);
  while not Eof(f) do begin
    Readln(f,d);
    if not Eof(f) then begin Inc(n); s:=s+d end
  end;
  Close(f);
  Assign(f,'output.txt'); Rewrite(f);
  mid:=s/n;
  Writeln(f,mid);
  Close(f);
end.


L4mer: Спасибо огромное
L4mer: Можешь решить ещё одну задачу
Аноним: Пожалуйста
L4mer: Блин я её только добавил в информатике
Аноним: Это риторический вопрос. Дело в желании.
Аноним: Я решаю задачи или дорогие, или интересные.
L4mer: Блин я просто с телефона не могу много поставить
L4mer: Вот я больше сделал. Прошу пожалуйста
Новые вопросы