Очень срочно
Напишите программу которая находит минимальное и максимальное среди чётных положительных чисел, записенных в файле, и выводит результат в другой файл. Учтите что таких чисел может вообще не быть
Ответы на вопрос
Ответил Аноним
3
const
lim=2000000;
var
d,max,min:longint;
f:Text;
begin
Assign(f,'input.txt'); Reset(f);
max:=-lim; min:=lim;
while not Eof(f) do begin
Readln(f,d);
if (d>0) and (d mod 2=0) then
if max<d then max:=d
else if min>d then min:=d;
end;
Close(f);
Assign(f,'output.txt'); Rewrite(f);
if min<>lim then Writeln(f,min,' ',max);
Close(f);
end.
lim=2000000;
var
d,max,min:longint;
f:Text;
begin
Assign(f,'input.txt'); Reset(f);
max:=-lim; min:=lim;
while not Eof(f) do begin
Readln(f,d);
if (d>0) and (d mod 2=0) then
if max<d then max:=d
else if min>d then min:=d;
end;
Close(f);
Assign(f,'output.txt'); Rewrite(f);
if min<>lim then Writeln(f,min,' ',max);
Close(f);
end.
L4mer:
Домой приду сделаю как лучший
Новые вопросы
Русский язык,
2 года назад
Українська література,
2 года назад
Геометрия,
2 года назад
География,
2 года назад
Алгебра,
7 лет назад