Информатика, вопрос задал raminq4113 , 6 лет назад

ОЧЕНЬ СРОЧНО

Дан программный код для следующей задачи: В первой строке записано целое число N(N<1018). Число N может быть только положительным. Подсчитайте количество четных и нечетных цифр в числе N.

Ответы на вопрос

Ответил xkpl0kpl0x
4

Ответ:

Код ниже

Объяснение:

n=int(input())

s, k = 0, 0

while n!=0:

   a=n%10

   n//=10

   if a%2==0:

       s+=1

   else:

       k+=1

print(s, k)

В начале вводим любое число (переменная N), меньше или равно числу 1018 (по условию), затем программа подсчитывает количество чётных и нечётных цифр в числе N.


В качестве примера возмём число 1008.
Программа выведет ответ "3 1".

3 - это чётные числа (0, 0 и 8)

1 - это нечётные числа (1)

Новые вопросы