ОЧЕНЬ СРОЧНО!!! ДАМ МНОГО БАЛЛОВ!!!
Как в Паскале написать программу:
Вывести первые n степеней числа 2, начиная с нулевой. Найти сумму цифр введенного числа.
Ответы на вопрос
Ответил 4EJIOBEK2000
1
Ответ:
var a,b,c,d:integer;
begin
writeln('введите число'); //запрос числа
readln(a);
d:=a; //это для красоты
while (a<>0) do begin //пока мы не дойдём до последней цифры в числе делать следующее
b:=a mod 10; //берём последнюю цифру числа
c:=c+b; //находим сумму цифр
a:=a div 10; //убираем из данного числа последнюю цифру
end;
writeln('сумма цифр числа ',d,' = ',c); // вывод результата
end.
Вроде вот)
egorovalizachif:
Спасчибо огромное!
Новые вопросы
Математика,
1 год назад
Информатика,
1 год назад
Другие предметы,
7 лет назад
Українська мова,
7 лет назад