Информатика, вопрос задал Flapbooker , 2 года назад

Очень срочно, C++.
Напишите программу, которая будет считывать четырехзначное число и выводить 1, если в нем ровно две одинаковые цифры, во всех остальных случаях программа выводит любое число.

Ответы на вопрос

Ответил uplmtq
0

Ответ:

#include <iostream>

using namespace std;

int main()

{

   int number;

   cin >> number;

   int array[4] = {};

   array[0] = number / 1000;

   array[1] = number % 1000 / 100;

   array[2] = number % 1000 % 100 / 10;

   array[3] = number % 10;

   int counter;

   int check = 0;

   for (int i = 0; i < 4; i++)

   {

       counter = 0;

       for (int j = 0; j < 4; j++)

       {

           if (array[i] == array[j])

           {

               counter++;

               if (counter == 2)

               {

                   check++;

               }

           }

       }

   }

   if (check != 0)

   {

       cout << 1;

   }

   else

   {

       cout << 0;

   }

}

Объяснение:

#include <iostream>  // Библиотека ввода-вывода

using namespace std;  // Пространство имён

int main()

{

   int number;  // Переменная для вводимого числа

   cin >> number;  // Ввод числа

   int array[4] = {};  // Массив для хранения цифр числа

   array[0] = number / 1000;  // Первая цифра

   array[1] = number % 1000 / 100;  // Вторая цифра

   array[2] = number % 1000 % 100 / 10;  // Третья цифра

   array[3] = number % 10;  // Четвертая цифра

   int counter;  // Переменная для подсчёта одинаковых цифр

   int check = 0;  // Переменная для проверки на само условие задачи

   for (int i = 0; i < 4; i++)

   {

       counter = 0;  // Обнуление переменной

       for (int j = 0; j < 4; j++)

       {

           if (array[i] == array[j])  // Если цифры равны

           {

               counter++;  // Увеличиваем на 1

               if (counter == 2)  // Если количество цифр = 2

               {

                   check++;  // Увеличиваем на 1

               }

           }

       }

   }

   if (check != 0)  // Если не равно 0

   {

       cout << 1;  // То выводим 1

   }

   else  // Иначе

   {

       cout << 0;  // Выводим 0 (любое значение)

   }

}

Новые вопросы