Информатика, вопрос задал polyana , 9 лет назад

Очень срочно!!!!!
1. Написать программу, в которой пользователь задает три стороны треугольника и которая выводит слово true, если треугольник равносторонний, и false, если не равносторонний.
2. Написать программу, в которой пользователь задает три стороны треугольника и которая выводит слово true, если треугольник равнобедренный, и false, если не равнобедренный.

Ответы на вопрос

Ответил KULON
0
1)
var
a,b,c: integer;
begin
read(a,b,c);
if (a=b) and(b=c) then
  writeln('true')
else writeln('false');
end.
2)
var
a,b,c: integer;
begin
read(a,b,c);
if (a=b) or (a=c) or (b=c) then
writeln('true')
else writeln('false');
end.
Ответил polyana
0
для лучшего ответа нужно решение нескольких человек
Ответил KULON
0
а, ясно)
Ответил polyana
0
Кстати, не integer, а boolean))) Но всё равно спасибо;-)
Ответил KULON
0
Нет, у меня все правильно, вы ошибаетесь. Тип boolean может принимать только 2 значения true и false.А здесь a,b,c - числа.
Ответил polyana
0
Что ж, признаю ошибку
Новые вопросы