Информатика, вопрос задал sadveter , 8 лет назад

очень нужна ваша помощь) нужно написать программу на паскале( как в примере)
Вариант- 5

Приложения:

Ответы на вопрос

Ответил allangarsk
0
№4const nx=30;var i,n,m,max,k,el,Sum,Sumnh:integer;C:Array[1..nx]of integer;Sr:real;BeginRead(n);for i:=1 to n do beginC[i]:= random(200)-100;  write(C[i]:4);if C[i]>0 then begin Sum := Sum + C[i];k:= k+1;end;if C[i]< 0 then m:= m+1;end;Sr:= Sum/k;writeln;writeln('среднеарифметическое положительных элементов ',Sr:6:4);write('Количес. отриц. элементов ',m:4);end.№5const nx=30;var i,n,m,max,k,el,Sum,Sumnh:integer;C:Array[1..nx]of integer;Sr:real;BeginRead(n);for i:=1 to n do beginC[i]:= random(125)-75;  write(C[i]:4);if C[i]>0 then begin Sum := Sum + C[i];k:= k+1;end;if C[i]< 0 then m:= m+1;end;Sr:= Sum/k;writeln;writeln('среднеарифметическое положительных элементов ',Sr:6:4);write('Количес. отриц. элементов ',m:4);end.
Новые вопросы