Информатика, вопрос задал friedstone , 8 лет назад

Очень нужна помощь с Паскалем!
Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке.

Входные данные
Входная строка содержит три целых числа, разделённых пробелами.

Выходные данные
Программа должна вывести количество одинаковых чисел из переданного ей набора или число 0, если все числа различные.

Ответы на вопрос

Ответил Аноним
0
Var
   a,b,c,k:integer;
Begin
k:=1;
Read(a,b,c);
if a=b then k:=k+1;
if b=c then k:=k+1;
if c=a then k:=k+1;
if k=1 then k:=0
else
   if k=4 then k:=3;
Write(k)
End.
Новые вопросы