Информатика, вопрос задал sasha1014346 , 7 лет назад

ОЧЕЕЕЕЕЕЕЕЕЕЕЕНЬ СРОЧНО

1)Составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с нечетными значениями в три раза, а элементы с четными значениями заменяя на 0.
2)Составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы.Выведите на экран исходный и полученный массивы.

Это нужно через PascalABC. ЗАРАНЕЕ ОГРОМНОЕ СПАСИБО

Ответы на вопрос

Ответил LikeSmileLJkee
0
1) var a:array [1..10] of integer;
i:integer;
begin
writeln('Генерируем массив со случайными числами');
for i:=1 to 10 do begin
a[i]:=random(100)+1;
write(a[i],' ');
end;
writeln;
writeln('Выполняем действие');
for i:=1 to 10 do begin
if (i mod 2 = 0) then a[i]:=0 else a[i]:=a[i]*3;
write(a[i],' ');
end;
readln;
end.

2) var a:array [1..10] of integer;
i,k:integer;
begin
writeln('Генерируем массив со случайными числами');
for i:=1 to 10 do begin
a[i]:=random(100)+1;
write(a[i],' ');
end;
writeln;
writeln('Выполняем действие');
k:=a[1];
a[1]:=a[10];
a[10]:=k;
for i:=1 to 10 do write(a[i],' ');
readln;
end.
Новые вопросы