Обращаюсь к информатикам!
Составить программу в Паскале для обработки одномерного массива из 15 чисел. Значения элементов массива задать с клавиатуры самостоятельно. Найти наименьший элемент массива и его номер.
Заранее огромное спасибо!!!
Ответы на вопрос
Ответил jefftop
0
Pascal ABC
Код:
var
a: array [1..15] of integer;
i, min: integer;
begin
//заполнение массива
for i := 1 to 15 do
readln(a[i]);
//поиск минимума
min := 1;
for i := 1 to 15 do
if a[min] > a[i] then min := i;
//вывод минимального и его номера
writeln('Минимум: ', a[min], ' Номер: ', min);
end.
Тесты:
Ввод:
4 5 7 8 9 2 1 3 4 5 8 7 6 8 2
Вывод:
Минимум: 1 Номер: 7
Новые вопросы
Математика,
2 года назад
Русский язык,
2 года назад
Биология,
7 лет назад
Математика,
9 лет назад
Алгебра,
9 лет назад