Информатика, вопрос задал MariaPerl , 10 лет назад

 Нужно составить программу, вычисляющую сумму только положительных чисел из трех вводимых с клавиатуры. в Турбо Паскале

Ответы на вопрос

Ответил igorvoloc
0
program picaso; uses crt;
var a,b,c,s:integer;
begin clrscr;
writeln('A:');read(a);
writeln('B:');read(b);
writeln('C:');read(c);
if(a > 0) then a:=a else a:=0;
if(b > 0) then b:=b else b:=0;
if(c > 0) then c:=c else c:=0;
s:=a+b+c;
writeln(s);
readln;
end.
Ответил Аноним
0
var a,b,c,ap,bp,cp:real;
begin
read(a,b,c);
if a>0 then ap:=a else ap:=0;
 if b>0 then bp:=b else bp:=0;
 if c>0 then cp:=c else cp:=0;
write  (ap+bp+cp);
end.
Новые вопросы