Информатика, вопрос задал bitnerone , 2 года назад

Нужно составить программу Pascal, в которой вводятся интервалы двух отрезков и число Х. Программа должна определять какому отрезку принадлежит это число. Без использования And и Or​


gfhjkmgfhjkm20: Интервалы и число Х - целые числа?
bitnerone: да

Ответы на вопрос

Ответил iknowthatyoufeelbro
0

Объяснение:

program kek;

var

 l1, r1, l2, r2, x: Integer;

begin

 read(l1, r1, l2, r2, x);

 if ((x-l1)*(r1-x) >= 0) then writeln('Первый отрезок.');

 if ((x-l2)*(r2-x) >= 0) then writeln('Второй отрезок.');

end.

Новые вопросы