Информатика, вопрос задал маша58reg , 10 лет назад

Нужно сделать блок-схему и написать программу. Получить квадратную матрицу

 

1111

1001

1001

1111

Ответы на вопрос

Ответил Sky09
0

Для ручного ввода элементов:

 

uses crt;
var a:array[1..4,1..4] of integer;
n,m:integer;
begin
  clrscr;
  writeln('vvod elementov:');
  for n:=1 to 4 do
    for m:=1 to 4 do
      read(a[n,m]);
  writeln('matrix:');
  for n:=1 to 4 do
  begin
    for m:=1 to 4 do
    write(a[n,m],' ');
    writeln;
  end;
end.

Приложения:
Новые вопросы