Нужно решить задачу на Pascal-е:
На вход программы подаются значения элементов двумерного массива А(mxn) (m, n <= 20). Преобразовать массив, поменяв местами элементы первой строки с элементами последней, второй с предпоследней и т.д.(т.е. повернуть массив вокруг горизонтальной оси). Результат вывести на экран.
Ответы на вопрос
Ответил ussrex
0
Ответ:
program mn;
uses crt;
const m=7;n=9;
var mas:array[1..m,1..n] of Integer ;
m1, m2:array[1..n] of Integer ;
i, j, k:Integer;
begin
Randomize;
write('Исходный массив:') ;
for i:=1 to m do begin
writeln;
for j:=1 to n do begin
mas[i, j]:=random(100);
write(mas[i, j]:3) end end ;
j:=0;
repeat
for i:=1 to n do begin
m1[i]:=mas[1+j,i];
m2[i]:=mas[m-j,i];
mas[1+j,i]:=m2[i];
mas[m-j,i]:=m1[i]; end;
j:=j+1
until j>m div 2;
writeln;
write('Преобразованный массив:') ;
for i:=1 to m do begin
writeln;
for j:=1 to n do
write(mas[i, j] :3) end;
readln;
end.
Объяснение:
В разделе const задаем нужный размер исходного массива.
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Физика,
7 лет назад
Математика,
7 лет назад