Информатика, вопрос задал SaidR , 7 лет назад

Нужно решить на Python


Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 20. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, делящееся нацело на 20.

Количество чисел не превышает 1000. Введенные числа не превышают 30 000.
Программа должна вывести одно целое число - минимальное число делящееся нацело на 20.

Входные данные
3
40
240
450
Выходные данные
40

Ответы на вопрос

Ответил vlajong
0

n=int(input())

min_na20=30000

for i in range(n):

 x=int(input())

 if x<min_na20 and x%20==0:

   min_na20=x

print(min_na20)

Новые вопросы