Информатика, вопрос задал armanshigapov09 , 1 год назад

нужно решить две задачи на питоне
1) Написать программу, которая будет переводить введенное число в любую систему счисления (2-9)
Показатель системы счисления и число вводятся с клавиатуры
Пример:
Ввод 13 2
Вывод 1011
2) Объявить список и заполнить его рандомными числами(int), введенными с клавиатуры
Вывести только те числа, которые являются простыми(делятся только на себя и на 1)
Пример:
Ввод a = [13, 17, 4, 20, 27, 28, 122]
Вывод
13

Ответы на вопрос

Ответил FrankenW
1

def convert_to_base(num, base):

   if num == 0:

       return '0'

   digits = []

   while num > 0:

       remainder = num % base

       digits.append(str(remainder))

       num //= base

   digits.reverse()

   return ''.join(digits)

number = int(input("Введіть число: "))

base = int(input("Введіть показник системи числення: "))

result = convert_to_base(number, base)

print(f"Результат: {result}")



AND


import random

def is_prime(n):

   if n <= 1:

       return False

   for i in range(2, int(n ** 0.5) + 1):

       if n % i == 0:

           return False

   return True

a = []

n = int(input("Введіть кількість чисел у списку: "))

for i in range(n):

   num = int(input(f"Введіть число #{i + 1}: "))

   a.append(num)

print("Прості числа зі списку: ")

for num in a:

   if is_prime(num):

       print(num)

Новые вопросы