Информатика, вопрос задал doodlee , 9 лет назад

Нужно решить 2 задачи по информатике:
1) дан массив B[1..10] составьте программу которая находит количество элементов, которые больше своего соседа слева
2) дан массив B[1..10] составьте программу которая находит количество пар элементов с четным значением

Ответы на вопрос

Ответил Аноним
0
Вот решение первой задачки:

program Sosed;
uses Crt;
const n = 10;
type  Vec = array [1..n] of integer;
var  A: Vec;
     i, Col: integer;
begin
 ClrScr;
 Randomize;

 WriteLn('Massiv A:');
 for i:=1 to n do
     begin
        A[i]:= 10+random (90);
        Write (A[i]:4);
     end;
 WriteLn;
 Col:=0;
 for i:=2 to n do
   begin
     if A[i]<A[i-1] then
       Col:=Col+1;
   end;
 WriteLn;
 if Col<>0 then  Writeln('Col =', Col)
           else WriteLn('None!');
ReadLn;
end.



Новые вопросы