Нужно написать программу в Паскале срочно: С клавиатуры вводится число n. Заполнить массив с клавиатуры n значениями и вывести их произведение.
Ответы на вопрос
Ответил HRAshton
0
var
a: array of byte; //Мы ведь не хотим выйти за пределы даже Int64?
n, i: byte; //Больше и не пригодится, массива из 255 значений хватит уж
l: Int64 := 1; //Произведение - большая цЫферка
begin
readln(n);
System.Array.Resize(a, n);
for i := 0 to (n - 1) do
begin
write('a[', i, '] = ');
readln(a[i]);
l *= a[i];
end;
writeln(l);
end.
a: array of byte; //Мы ведь не хотим выйти за пределы даже Int64?
n, i: byte; //Больше и не пригодится, массива из 255 значений хватит уж
l: Int64 := 1; //Произведение - большая цЫферка
begin
readln(n);
System.Array.Resize(a, n);
for i := 0 to (n - 1) do
begin
write('a[', i, '] = ');
readln(a[i]);
l *= a[i];
end;
writeln(l);
end.
Новые вопросы