Информатика, вопрос задал jstilvo , 10 лет назад

Нужно написать программу в паскале АВС

Даны целые положительные числа N и K. Найти сумму:

1(в степени к)+2(в степени к)+...+N(в степени к).

Ответы на вопрос

Ответил arsenteva1
0
a = k
в цикле
sum=sum+a
a=a*k
Ответил jstilvo
0
program proba;
var a,c,s,N,K:real; i,j:integer;
begin
readln (N,K);
a:=1; s:=0;
While a<=N do begin
c:=exp(K*ln(a));
s:=s+c;
a:=a+1;
end;
writeln (s);
end.
Новые вопросы