Нужно написать программу в Pascal: пользователь вводит число в десятичной системе, а программа должна перевести это число в двуичный код. Желательно сделать 1 программу простой, с использованием if, div, mod, ну и циклы если надо,кроме цикла repeat, например пользователь ввёл 5 а система перевела в двуичный код 101
LRSM:
Уже лучше) Только с отрицательными числами как быть? Например, во что переводить -5? Или программа должна быть только для натуральных чисел?
Ответы на вопрос
Ответил kolobok9805
0
Ответ:
program ToBinary;
procedure dec2bin(var s : string; num : integer);
begin
if num > 0 then begin
dec2bin(s, num div 2);
if num mod 2 = 0 then
s := s + '0'
else
s := s + '1';
end;
end;
var
a : integer;
s : string;
begin
read(a);
dec2bin(s, a);
writeln(s);
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
2 года назад
Алгебра,
2 года назад
Биология,
8 лет назад