Нужно написать программу в Pascal'е. Задание описано так. Требуется выделить из предложения четвертое слово (слова разделены пробелом).
Ответы на вопрос
Ответил vunderkid
0
var
s: string;
i: integer;
qp: integer;
word: string;
begin
writeln('Введите предложение разделяя слова пробелами');
readln(s);
qp:=0;
word:='';
for i:=1 to length(s) do begin
if s[i]=' ' then
qp:=qp+1
else begin
if qp=3 then word:=word+s[i];
end;
if qp=4 then
break;
end;
if word='' then
writeln('четвёртое слово не присутствует')
else
writeln('искомое слово - ', word);
end.
{Пример}
На pascal написана соответствующая программа
искомое слово - соответствующая
s: string;
i: integer;
qp: integer;
word: string;
begin
writeln('Введите предложение разделяя слова пробелами');
readln(s);
qp:=0;
word:='';
for i:=1 to length(s) do begin
if s[i]=' ' then
qp:=qp+1
else begin
if qp=3 then word:=word+s[i];
end;
if qp=4 then
break;
end;
if word='' then
writeln('четвёртое слово не присутствует')
else
writeln('искомое слово - ', word);
end.
{Пример}
На pascal написана соответствующая программа
искомое слово - соответствующая
Новые вопросы
Математика,
2 года назад
Українська мова,
2 года назад
История,
8 лет назад
Физика,
8 лет назад
Алгебра,
9 лет назад
Обществознание,
9 лет назад