Информатика, вопрос задал sackovae964 , 7 лет назад

Нужно написать программу python, while, которая находит количество троек.


restIess: троек где? в строке/в числе/в списке?
sackovae964: В заданом числе. Число вводит пользователь

Ответы на вопрос

Ответил restIess
0

a = abs(int(input()))

_counter = 0

while a > 0:

   if a % 10 == 3:

       _counter += 1

   a //= 10

print(_counter)


sackovae964: Нужно изменить эту:
sackovae964: n=int(input('Введите число:')) k=0 while n>0 if n%10==1 k+=1 n//=10 print('Количество единиц:', k
restIess: почти тоже самое, буквы ток другие
restIess: и за что отметка о нарушении?)
sackovae964: Это не та программа вообще
restIess: С чего вдруг она не та?)
nikniklas: неправильная постановка задачи значит. надо снять бан
Новые вопросы