Информатика, вопрос задал EvaWinchester , 9 лет назад

Нужно написать программу на языке Турбо Паскаль, которая бы вычисляла значение выражения по формуле
(a/c)*(b/d)-((a*b-c)/(c*d))* e^{x+y}

e^(x+y) - степень!

Заранее спасибо

Ответы на вопрос

Ответил Аноним
0
var
  a, b, c, d, e, x, y, z: real;

begin
  Write('Введите через пробел a,b,c,d,e,x,y: ');
  Readln(a, b, c, d, e, x, y);
  if e > 0 then
    Writeln((a / c) * (b / d) - ((a * b - c) / (c * d)) * exp((x + y) * ln(e)))
  else if e = 0 then Writeln((a / c) * (b / d) - ((a * b - c) / (c * d)))
  else Writeln('e<0 недопустимо!')
end.

Новые вопросы