Нужно написать программу на языке С++ которая должна:
Проверить трехзначное число на четность и найти сумму его цифр, если число четное, или произведение его цифр, если число нечетное.
Ответы на вопрос
Ответил BobbyFresnel
1
#include <iostream>
using namespace std;
int main()
{
int n;
cin >> n;
n = abs(n); // если введут отрицательное
if(n > 99 && n < 1000)
{
int d1, d10, d100;
d1 = n % 10;
d100 = n / 100;
d10 = n / 10 % 10;
int r;
if(n % 2 == 0)
r = d100 + d10 + d1;
else
r = d100 * d10 * d1;
cout << r;
}
else
cout << "Число не трехзначное";
return 0;
}
1223445565:
Да ты волшебник)
Новые вопросы
Английский язык,
1 год назад
Английский язык,
1 год назад
Математика,
1 год назад
Қазақ тiлi,
7 лет назад