Нужно написать программу на языке С++:
Дана последовательность целых чисел, за которой следует 0. Найти разность минимального и максимального элементов в этой последовательности.
Ответы на вопрос
Ответил Аноним
0
#include<iostream>
using namespace std;
int main()
{
int A;
cin >> A;
int Min = A;
int Max = A;
while(A)
{
cin >> A;
if (Max < A && A!=0) Max = A;
if (Min > A && A!=0) Min = A;
}
cout <<"Min = "<<Min<<"n";
cout <<"Max = "<<Max<<"n";
cout <<"Min - Max = "<<Min-Max<<"n";
return 0;
}
using namespace std;
int main()
{
int A;
cin >> A;
int Min = A;
int Max = A;
while(A)
{
cin >> A;
if (Max < A && A!=0) Max = A;
if (Min > A && A!=0) Min = A;
}
cout <<"Min = "<<Min<<"n";
cout <<"Max = "<<Max<<"n";
cout <<"Min - Max = "<<Min-Max<<"n";
return 0;
}
Новые вопросы