Информатика, вопрос задал beenchmark , 9 лет назад

нужно написать программу на языке Паскаль, которая будет убирать из строки все символы кроме цифр. Пример: входной- a3f4h5k&2 выходной:3452

Ответы на вопрос

Ответил ZusTY
0
var s:string;
l,i:longint;
begin
read(s);
l:=length(s);
for i:=1 to l do
if (s[i]>='0')and(s[i]<='9') then write(s[i]);
end.
Ответил beenchmark
0
там блин как-то диапозон можно выставить, а я забыл как =)
Ответил Segrif
0
if (s[i] >= '0') and (s[i] <= '9')
По стандарту языка, вроде как, цифры должны идти по порядку
Ответил ZusTY
0
да, ты прав
Ответил srzontmp
0
А где удаление символов из строки, как в задании написано?
Ответил beenchmark
0
там смотри условие, если данный символ число то печатать его крч =)
Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  var s:=ReadlnString;
  s:=s.Where(d->d in ['0'..'9']).JoinIntoString('');
  Writeln(s)
end.

Тестовое решение:
a3f4h5k&2
3452
Новые вопросы