Нужно написать программу на с++. Я сама написала программу ниже, но когда я ввожу 2, вместо -0.5 выходит 1.5. Помогите найти ошибку, пожалуйста.
Приложения:


Аноним:
вместо n везде i
Ответы на вопрос
Ответил Аноним
0
Ответ:
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
int n;
cin >> n;
int p = 1;
float sum = 0;
for (float i = 1; i <=n; i++)
{
p *= i;
sum += (pow(-1, i) * (i + 1)) / (p);
}
cout << sum;
}
//вместо n ты должна была написать i
Новые вопросы