Нужно написать программу на с++, которая будет решать введенные в нее производные, например 2x^5 = 10x^4, cosx = - sinx, вычислять ответ производной не нужно.
Ответы на вопрос
Ответил clinteastwood2
0
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64
#include <iostream>
#include <string>
#include <vector>
#include <utility>
int main()
{
std::vector<std::pair<std::string, std::string>> deriv_sheet = {
std::make_pair("2x^5", "10x^4"),
std::make_pair("cosx", "-sinx")
};
std::string user_fx;
std::cin >> user_fx;
for (const auto& i : deriv_sheet )
if (i.first.compare(user_fx) == 0)
std::cout << i.second;
}
#include <iostream>
#include <string>
#include <vector>
#include <utility>
int main()
{
std::vector<std::pair<std::string, std::string>> deriv_sheet = {
std::make_pair("2x^5", "10x^4"),
std::make_pair("cosx", "-sinx")
};
std::string user_fx;
std::cin >> user_fx;
for (const auto& i : deriv_sheet )
if (i.first.compare(user_fx) == 0)
std::cout << i.second;
}
Ответил Аноним
0
Ну вот....ссылки публиковать нельзя, к обсуждению не пригласишь куда-то, потому что не будешь же светить тут свои логины. Остается только тут.
Ответил clinteastwood2
0
Жестоко, как всегда..
Ответил Аноним
0
https://znanija.com/task/29277524 - вот условие, просто песня ))
Ответил clinteastwood2
0
Смотрите, здесь Эникей выше давал пример, одного из решений вашей проблемы, но как и ранее было сказано, нужна адекватная постановка задания, незачем плодить новые темы, там вам вряд ли дадут ответ "лучше".
Ответил clinteastwood2
0
Я считаю, возможен вариант построение синтаксического дерева, которое анализировало бы введенную fx и в соответствии могло принимать меры.. Как вариант часть производных типо cosx = - sinx можно подставлять из файла например где есть некая табличка
Новые вопросы