Информатика, вопрос задал bogdan2959 , 2 года назад

нужно написать программу на пайтон чтобы она работала примерно по такому шаблону

Приложения:

bogdan2959: функция get_info() должна возвращать значение — список с информацией об ученике.
bogdan2959: вот
mrvv958: тааак
mrvv958: т.е она не должна из своей памяти это брать?
mrvv958: тогда начало примерно такое
mrvv958: def get_info():
input_surname = input("Введите фамилию ученика: ")
input_lessons = input("Введите предметы через запятую").split(", ")
mrvv958: listPupils = [str(input_surname), input_lessons]
mrvv958: но инпут лесонс может быть списком, так что в итоге мы можем получить список в списке а именно [a, ["wd", "wde"]]
mrvv958: Всё. Всё подправил.
mrvv958: у меня код чутка покороче

Ответы на вопрос

Ответил TheEpic73
2

students = {}

count_ = 0

while True:

   if count_ == 2:

       break

   last_name = input("Фамилия студента: ")

   subjects = input("Профильные предменты:")

   students.update({last_name: subjects.split(", ")})

   count_ += 1

for last_name in students.keys():

   print('Анкета студента')

   print(f"Фамилия - {last_name}")

   print("Профильные предменты:")

   for i in range(1, len(students[last_name]) + 1):

       sub = students[last_name][i - 1]

       print(f"{i} - {sub}")


mrvv958: так можно же через запятую хоть 100 ввести
mrvv958: зачем же тогда сплит
TheEpic73: count это для самих людей
mrvv958: так 2х людей надо было?‍♂️
mrvv958: чото эмодзи тут нормально не работают
bogdan2959: да
TheEpic73: +1 происходит только после добавления человека
bogdan2959: 2 человека
TheEpic73: Не предмета
mrvv958: понятно. Ща у себя поправлю
Ответил mrvv958
1

def get_info():

   count = 1

   for i in range(2):

       input_surname = input("Фамилия студента: ")

       input_lessons = input("Профильные предметы").split(", ")

       print(f"Фамилия ученика - {input_surname}\nПрофильные предметы:")

       for i in input_lessons:

           print(count, "-", i)

           count += 1

get_info()


bogdan2959: в четвертой строке ошибка
bogdan2959: if count_ == 2:
mrvv958: незнаю у меня код работает
mrvv958: предметы правда выводит чутка некорректно, но эо ща поправляю
bogdan2959: а после какой строки можно добавить print('Анкета студента')
bogdan2959: там просто аткое в условии есть
Новые вопросы