Нужно написать программу на Паскале: В матрице размера M×N положительные элементы заменить единицей. Создание и вывод матриц оформить в виде процедур.
Ответы на вопрос
Ответил Аноним
0
PascalABC.NET 3.4.0, сборка 1675 от 12.06.2018
Внимание! Если программа не работает, обновите версию!
procedure MatrixCreate(m,n:integer; var A:array[,] of integer);
begin
A:=MatrRandom(m,n,-50,50);
end;
procedure MatrixOutput(A:array[,] of integer);
begin
A.Println(4)
end;
begin
var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
var a:array[,] of integer;
MatrixCreate(m,n,a);
Writeln('*** Исходная матрица ***');
MatrixOutput(a);
a.Transform(t->t>0?1:t);
Writeln('*** Полученная матрица ***');
MatrixOutput(a);
end.
Внимание! Если программа не работает, обновите версию!
procedure MatrixCreate(m,n:integer; var A:array[,] of integer);
begin
A:=MatrRandom(m,n,-50,50);
end;
procedure MatrixOutput(A:array[,] of integer);
begin
A.Println(4)
end;
begin
var (m,n):=ReadInteger2('Количество строк и столбцов в матрице:');
var a:array[,] of integer;
MatrixCreate(m,n,a);
Writeln('*** Исходная матрица ***');
MatrixOutput(a);
a.Transform(t->t>0?1:t);
Writeln('*** Полученная матрица ***');
MatrixOutput(a);
end.
Приложения:

Ответил joltepak
0
сделала как написали, набрала вручную,теперь ошибка на 10ой...
Ответил joltepak
0
версия 3.2 сборка 1361 (1)
Ответил joltepak
0
1361 (13.12.2016)
Ответил Аноним
0
А указана какая версия? И что ниже написано во второй строке? ОБНОВИТЬ!
Ответил Аноним
0
Вам лень было прочитать первые две строки ответа и Вы уже четверть часа ищете несуществующие ошибки.
Новые вопросы