Информатика, вопрос задал 1mopsss1 , 7 лет назад

Нужно написать программу на c++
В файле хранится двумерный массив размерностью n*n элементов. Определить сумму квадратов всех чётных элементов

Ответы на вопрос

Ответил restIess
0

#include <iostream>

#include <fstream>

#include <cmath>

#define n 3

signed main()

{

   setlocale(LC_ALL, "Ru");

   std::ifstream fRead("имя файла сюда");

   int matrix[n][n];

   long int _sum = 0;

   if (fRead.good()) {

       for (int i = 0; i < n; i++)

           for (int j = 0; j < n; j++)

               fRead >> matrix[i][j];

   }

   else {

       std::cout << "Ошибка в открытии файла!";

       return 0;

   }

   for (int i = 0; i < n; i++) {

       for (int j = 0; j < n; j++) {

           std::cout << matrix[i][j] << " ";    

           if (matrix[i][j] % 2 == 0)

               _sum += pow(matrix[i][j], 2);

       }

       std::cout << std::endl;

   }

   std::cout << _sum << std::endl;

   return 0;

}

Новые вопросы