Информатика, вопрос задал marblefloors , 2 года назад

Нужно написать программу на c++ по данному заданию (даю 100 баллов)

Задан квадратный массив А из N строк и N столбцов, N – нечетное число. В предложенном массиве можно выделить две диагонали. Эти диагонали очерчивают четыре треугольника с числами. Произвести замену верхнего и нижнего треугольников, правого и левого треугольников.

Ответы на вопрос

Ответил lexa23072003
1

#include <iostream>

using namespace std;

int main()

{

int N, N1;

cout << "kol-vo ctrok ";

cin >> N;

cout << "ko-lvo ctolbcov ";

cin >> N1;

int** mtrx = new int* [N1];

for (int i = 0; i < N; i++)

{

 mtrx[i] = new int[N1];

}

for (int i = 0; i < N; i++)

{

 for (int j = 0; j < N1; j++)

 {

  cin >> mtrx[i][j];

 }

}

cout << endl;

for (int i = 0; i < N; i++)

{

 for (int j = 0; j < N1; j++)

 {

  cout<< mtrx[i][j]<<" ";

 }

 cout << endl;

}

for (int i = 0; i <= trunc(N/2); i++)

{

 for (int j = 0; j <= trunc(N1/2); j++)

 {

  int tmp = mtrx[N - 1 - i][N1-1-j];

  mtrx[N - 1 - i][N1 - 1 - j] = mtrx[i][j];

  mtrx[i][j] = tmp;

 }  

}

cout << endl;

for (int i = 0; i < N; i++)

{

 for (int j = 0; j < N1; j++)

 {

  cout << mtrx[i][j] << " ";

 }

 cout << endl;

}

for (int i = 0; i < N; i++)

{

 delete[] mtrx[i];

}

delete [] mtrx;

   return 0;

}


lexa23072003: если че то не так пиши
maxpavlutenkof: зачем через динамическую матрицу создавать было, если ты не передаешь ее в функции ? Автор вопроса же хер поймет (но эт не точно)
maxpavlutenkof: *делать было
lexa23072003: сори
lexa23072003: там было сказано ввести
lexa23072003: а вводить можно ток динамическую
maxpavlutenkof: нет, динамическую юзают тогда, когда а) на момент компиля не известен размер б) нужно передавать матрицу в функции, в остальном этот метод сложнее и опаснее
marblefloors: благодарю, это то что надо
lexa23072003: все норм
Новые вопросы