Информатика, вопрос задал petuhov003 , 7 лет назад

нужно написать программу которая вычисляет полную площадь поверхности цилиндра. значения высоты и радиуса водятся с клавиатуры

Язык C

можно исправить ошибки в моём коде

#include

#include

main()

{

int h =0;

int r=0;

int p=3.14;

int P=0;

printf("Введите первое целое число\n");

scanf("%d", &h);

printf("Введите второе целое число\n");

scanf("%d", &r);

P=2*p*r*(h+r);

printf ("%d",P);

getch();

}

Ответы на вопрос

Ответил lsdrfrx
0

Переменные P и p должны быть вещественного типа, так как они представляют собой дробные числа. Какая ошибка выводится? CE или RE?

Новые вопросы