Нужно написать программу, которая сформировывает случайным образом 10 чисел в интервале от -100 до 100 и находит среднее арифметическое положительных чисел, являющихся нечетными.
Программа должна быть выполнена в том же стиле, что и программа на фото, так по заданию.
Пожалуйста, помогите. Сколько пытаюсь... не выходит...
Приложения:

Ответы на вопрос
Ответил petyaGavrikov
0
const n=10;
var a,s,k,i:integer;
begin
Randomize;
s:=0; k:=0;
writeln('Числа:');
for i:=1 to n do
begin
a:=random(201)-100;
write(a:5);
if (a>0)and(a mod 2 = 1) then begin s:=s+a; k:=k+1; end;
end;
writeln;
if k>0
then writeln('Среднее арифметическое положительных нечетных чисел = ',s/k:5:2)
else writeln('Среди чисел нет положительных нечетных');
end.
Пример:
Числа:
11 -60 13 -62 15 -92 -71 87 -15 12
Среднее арифметическое положительных нечетных чисел = 31.50
var a,s,k,i:integer;
begin
Randomize;
s:=0; k:=0;
writeln('Числа:');
for i:=1 to n do
begin
a:=random(201)-100;
write(a:5);
if (a>0)and(a mod 2 = 1) then begin s:=s+a; k:=k+1; end;
end;
writeln;
if k>0
then writeln('Среднее арифметическое положительных нечетных чисел = ',s/k:5:2)
else writeln('Среди чисел нет положительных нечетных');
end.
Пример:
Числа:
11 -60 13 -62 15 -92 -71 87 -15 12
Среднее арифметическое положительных нечетных чисел = 31.50
Ответил Аноним
0
Здесь решают задачи не так, чтобы решение было обязательно, похоже на "как мы в классе пишем", а чтобы оно просто было верным. Поскольку смысл этого Сервиса совсем не в том, чтобы давать решения, которые потом Вы будете пытаться выдать за свои.
Ответил Аноним
0
Посему если Вы будете в продолжать писать в заданиях "Программа должна быть выполнена в том же стиле, что и программа на фото...", такие задания будут удаляться.
Новые вопросы