Информатика, вопрос задал svi10m , 7 лет назад

Нужно написать программу, которая переводит десятичные числа в двоичные. На языке Паскаль.
!!!Очень срочно!!!

Ответы на вопрос

Ответил marataglyamov
0

Program l;

var

n: integer;

s: String;  

begin  

readln(n);  

while n>0 do begin  

insert(chr(48+n mod 2),s,1);  

n:=n div 2;  

end;  

writeln(s);  

end.

Ответил Аноним
0

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger('Введите натуральное десятичное число:');

 var r: string := '';

 while n >= 2 do

   (r, n) := (n mod 2 + r, n shr 1);

 r := '1' + r;

 r.Println

end.

Приложения:
Новые вопросы