Информатика, вопрос задал nikitazlorodok , 1 год назад

Нужно написать программу
Дана строка длинной N, символов. Определить сколько различных символов встречается в строке. Вывести их в алфавитном порядке, через знак "-" указав их количество.В первой строке записано число N, количество символов. Во второй строке записана последовательность символов. Допустимые символы: малые и большие латинские буквы и цифры. Причем цифра стоит раньше буквы в нашем алфавите.В первую строку выходного файла необходимо вывести количество различных символов в строке. Далее в алфавитном порядке идут строки, в которых записан символ последовательности знак "-" и количество.

Ответы на вопрос

Ответил MrFlyguy
1

На языке python:

N = int(input())

s = input()

ss = sorted(list(set(s)))

print(len(ss))

for i in ss:

   print(f'{i}-{s.count(i)}')

Ответил pb1036
0

## // PascalАВС.NЕТ 3.9

var (n, s) := (ReadlnInteger, ReadString);

var d := s.ToLower.MatchValues('[a-z\d]').Sorted.EachCount;

d.Count.Println;

d.PrintLines(r -> $'{r.Key}-{r.Value}')


pb1036: Если нужно различать строчные и прописные буквы, var d := s.MatchValues('[A-Za-z\d]').Sorted.EachCount;
Новые вопросы