Информатика, вопрос задал Nikname123123123 , 8 лет назад

Нужна прога в синтаксисе PASCAL ABC
Составить программу матрицу 10х10, заполненную случайным образом
Посчитать сумму элементов главной диагонали
Определить количество элементов < сумма/15
var
a:array[1..10,1..10] of integer;
i,j,summ,kol:integer;
begin
randomize
и тд
за ответ 30 баллов

Ответы на вопрос

Ответил Аноним
0
PascalABC.NET 3.3 под девизом
"Памяти наших дедов посвящается..."


const
  n=10;
var
  a:array[1..n,1..n] of integer;
  i,j,SumDiag,k:integer;
  p:real;

begin
  Writeln('*** Исходная матрица ***');
  Randomize;
  SumDiag:=0;
  for i:=1 to n do begin
    for j:=1 to n do begin
      a[i,j]:=Random(199)-99;
      if i=j then SumDiag:=SumDiag+a[i,j];
      Write(a[i,j]:4)
      end;
    Writeln
    end;
  for i:=1 to 4*n do Write('-');
  Writeln;
  Writeln('Сумма элементов на главной диагонали ',SumDiag);
  p:=SumDiag/15;
  k:=0;
  for i:=1 to n do
    for j:=1 to n do
      if a[i,j]<p then k:=k+1;
  Writeln('Искомое количество элементов ',k)
end.

Пример
*** Исходная матрица ***
  95  37  30  21  83 -99  48 -40  49 -19
 -66 -82  88 -24  70  14 -88  11  60  14
 -72 -80  90  25  68  23  91  66 -54  52
  33  16  25 -72  85  58 -39  44   8 -29
   8  78 -79  51  50 -61 -13 -87  87  66
  63 -45  94 -48  59  76  46 -94  53 -40
 -90  81 -85  96  47  18  -8  61 -10 -87
 -47 -33 -97 -10 -93 -51  98 -60  74  30
 -63  78  79 -21  89 -21  21 -26 -31 -91
 -88 -45  91 -51 -39  26  64 -75 -96 -67
----------------------------------------
Сумма элементов на главной диагонали -9
Искомое количество элементов 46
Новые вопросы