Информатика, вопрос задал fearyt98 , 10 лет назад

Нужна помощь: Составить программу по которой компьютер угадает число введеное с клавиатуры (с помощью repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем)

Ответы на вопрос

Ответил Kitsu
0

var x,y,a:integer;
c:boolean;
begin
readln(x); {считываем}

a:=1;
repeat

writeln(a,' попытка выбор компьютера пал на - ');
y:=random(x)+1; {задаем промежуток рандомом}

write(y);
if x=y {сравниваем} then c:=true; {выходим из цикла в случае успеха}
until c; {если с=true тогда выход из цикла, иначе крутимся дальше}

writeln('Компьютер сделал ',a,' попыток.');
end.


Более доработанная и понятная, если возникают какие-то вопросы - пиши в личку.

Новые вопросы