Нужна помощь по информатике. Задача:
Написать программу вычислить произведение из двух наибольших введенных с клавиатуры чисел.( в ПАСКАЛЕ). Проще говоря, у меня есть три числа, я должен ввести их, и два наибольших из них должны перемножаться. Нужно написать программу используя условные операторы. Заранее спасибо.
Ответы на вопрос
Ответил HiroX
0
var m: array [1..3] of real;
var i, imin, imax: integer;
var num, pro: real;
begin
imin:=1;
imax:=1;
for i:=1 to 3 do read (m[i]);
for i:=1 to 3 do
begin
if m[i]<m[imin] then imin:=i;
if m[i]>m[imax] then imax:=i;
end;
num:=m[1]+m[2]+m[3]-m[imin]-m[imax];
pro:=num*m[imax];
write (pro);
end.
var i, imin, imax: integer;
var num, pro: real;
begin
imin:=1;
imax:=1;
for i:=1 to 3 do read (m[i]);
for i:=1 to 3 do
begin
if m[i]<m[imin] then imin:=i;
if m[i]>m[imax] then imax:=i;
end;
num:=m[1]+m[2]+m[3]-m[imin]-m[imax];
pro:=num*m[imax];
write (pro);
end.
Ответил Аноним
0
var
a,b,c:integer;
begin
Write('Введите три целых числа: '); Readln(a,b,c);
if a>b then
if b>c then Writeln(a*b) else Writeln(a*c)
else
if a>c then Writeln(a*b) else Writeln(b*c)
end.
Тестовое решение:
Введите три целых числа: 5 -2 7
35
a,b,c:integer;
begin
Write('Введите три целых числа: '); Readln(a,b,c);
if a>b then
if b>c then Writeln(a*b) else Writeln(a*c)
else
if a>c then Writeln(a*b) else Writeln(b*c)
end.
Тестовое решение:
Введите три целых числа: 5 -2 7
35
Новые вопросы
Информатика,
2 года назад
Математика,
2 года назад
Физика,
9 лет назад
Математика,
10 лет назад
Математика,
10 лет назад