Информатика, вопрос задал Муримил , 7 лет назад

Нужна помощь.
А. Напишите программу подсчета количества положительных, отрицательных чисел и чисел, равных нулю.

В. Перепишите следующую программу без ошибок и определите, какое значение будет иметь переменная P после выполнения программы, если с клавиатуры введено число 10?

PROGRAM OL;

Var a;b;h:integer

BEGIN

WriteLn(‘Введите число’ );

ReadLn(a);

If a>=2 and a<=14

then

begin

b:=3;

p=a*a+b*b

end;

else b:=5;

p:=(a+b)*(a+b);

WriteLn(‘p=’p);

END

Ответы на вопрос

Ответил csharp
0

Задание А

Прикрепил в файле исходный код программы

Задание B

Прикрепил файл с исправленной программой, в которой присутствуют пометки, объясняющие ошибки. Ответ на второй вопрос:

При a = 10 переменная p примет значение 169.

Приложения:
Ответил Муримил
0
и снова, спасибо♥♥♥♥
Новые вопросы