Информатика, вопрос задал Аноним , 6 лет назад

Нужен код на С++, помогите, пожалуйста
Составить программу для нахождения пифагоровых троек. Пифагоровой тройкой называют такие целые числа a, b и c, удовлетворяющие условию a^2 + b^2 = c^2. Известно, что существует прямоугольный треугольник с длинами сторон. Найдите все пифагоровые тройки для c<5.

Ответы на вопрос

Ответил лекция
1

таких троек нет)

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

   for (int a = 1; a < 4; a ++)

   {

       for (int b = 1; b < 4; b ++)

       {

           for (int c = 1; c < 5; c ++)

           {

               if ( pow(a, 2) + pow(b, 2) == pow(c, 2) ) cout << a << " " << b << " " << c << "\n";

           }

       }

   }

}

Новые вопросы