Информатика, вопрос задал vladvasilev318 , 2 года назад

Нужен код для Пайтона и блок-схема.
Написать программу, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика. Параметр R задается константой.

Приложения:

Ответы на вопрос

Ответил pinguinbird
1

Ответ:

from math import sqrt, pow, pi, sin

R = 2

chk = False

while chk == False:

   try:

       x = float(input("Введите аргумент функции f(x). Область определения функции [-9; 5]: "))

       if x < -9 or x > 5: print("Введённый аргумент вне области определения функции f(x).")

       else:

           chk = True

           if x >= -9 and x < -5: print(F"f({x}) = {round(R-sqrt(pow(R,2)-pow((x+7),2)),2)}")

           if x >= -5 and x < -4: print(F"f({x}) = 2")

           if x >= -4 and x < 0: print(F"f({x}) = {round(abs(x/2),2)}")

           if x >= 0 and x < pi: print(F"f({x}) = {round(sin(x),2)}")

           if x >= pi and x <= 5: print(F"f({x}) = {round(x-pi,2)}")

   except ValueError:

       print("Неверный формат числа.")

Приложения:

pinguinbird: Меня немного смущает фраза "Параметр R задаётся константой". То есть его получается можно не только равный 2 задать? Если так, то надо кое что переписать, но там тоже могут быть подходы разные...так что я пока так оставлю, в принципе должно устроить... В принципе всё будет работать на разных R и так, просто по-разному можно написать в зависимости от требований, которых тут недостаточно. Так что оставляю как есть. Удачи )
pinguinbird: Да, и было бы круто, если бы Вы пометили мой ответ как Лучшее решение. Остался последний до статуса Отличник :) Заранее спасибо.
vladvasilev318: думаю надо доработать
vladvasilev318: хотя нет, спасибо. Было бы хорошо если вы помогли ещё раз
pinguinbird: а что вы хотели доработать? просто интересно :)
vladvasilev318: уже не надо спасибо, было-бы хорошо если вы бы помогли сделать новое задание
Новые вопросы