Информатика, вопрос задал lenaaaaa71 , 2 года назад


Нижний регистр

На вход программе подается строка. Напишите программу, которая подсчитывает количество буквенных символов в нижнем регистре.

Ответы на вопрос

Ответил vimmortal2
0

Программа:

Python:

st, count = input('Введите строку: '), 0

for i in st:

   if i.islower():

       count += 1

print(count)

Объяснение:
В начале регистрируются переменные st и count. Для st вводится строка с клавиатуры, count равен нулю - для будущих вычислений. С помощью цикла for проходимся по каждому символу строки и делаем проверку, записан ли этот символ в нижнем регистре. Если да (True), значение переменной count увеличивается на 1. Когда цикл пробежится по всем элементам, выведется само количество символов.

Новые вопросы