Информатика, вопрос задал tema3093139 , 7 лет назад

Ниже на четырёх языках программирования записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: L и M. Укажите наименьшее число x, при вводе которого алгоритм печатает сначала 2, а потом 6.

Нужен код программы на Python

Приложения:

Ответы на вопрос

Ответил UKRedBoy
0

Ответ:

65

Объяснение:

def ddd(x):

   L=0

   M=0

   while x >0:

       M=M+2

       if x%8 !=0:

           L=L+1

       x=x//8

   return (L,M)

i=0

for i in range(100):

   print(ddd(i))

   print(i)


tema3093139: Спасибо! А нельзя ли это сделать через дополнительный цикл while?
Новые вопросы