Информатика, вопрос задал LastShadow , 10 лет назад

Необходимо составить программу с двумерным массивом. Для заполнения данного массива нужно использовать генератор случайных чисел.
I - отвечает за номер строки.
J - отвечает за номер столбца.
Заполненные массивы должны выглядеть так:
при const n=3 
1 2 1
2 3 2
1 2 1
при const n=5
1 2 3 2 1
2 1 2 1 2
3 2 1 2 3
2 1 2 1 2
1 2 3 2 1
Желательно, составить блок-схему.

Ответы на вопрос

Ответил preceptor
0
В программе две константы: n и m. n отвечает за размер массива, m за максимальное значение случайного числа от  0 до на 1 меньше чем само m.

Program Zadacha;
Const n = 5; m = 5;
Var a: Array [1..n, 1..n] of Integer;
i, j: Integer;
Begin
Randomize;
For i := 1 To n Do
For j := 1 To n Do
a[i, j] := Random(m);
WriteLn('Результат:');
For i := 1 To n Do
Begin
For j := 1 To n Do
Write(a[i, j], ' ');
WriteLn;
End;
ReadLn;
End.
Новые вопросы