Информатика, вопрос задал margaritagvozdkova45 , 7 лет назад

необходимо написать программу выводящую кортеж содержащий числа в полуинтервале [a ;b) если a <b и[b ;a)если b<a числа а и b вводятся с клавиатуры​

Ответы на вопрос

Ответил HappyCoder
0

Ответ:

  • var
  •  a, b, n, i: integer;
  • begin
  •  Writeln('Введите два числа через пробел: ');
  •  Read(a, b);
  •  if a < b then
  •    n := b - a
  •  else n := a - b;
  •  for i := 1 to n do
  •    if a < b then
  •    begin
  •      a += 1;
  •      Write(a, ' ');
  •    end
  •    else if b < a then begin
  •      a -= 1;
  •      write(a, ' ');
  •    end;
  • end.

Приложения:
Новые вопросы